Remont Flippera MONTE CARLO Gottlieb 1986r.

Czyli, jak zostałem hazardzistą…

Flippera wypatrzyłem na znanym portalu aukcyjnym w stanie jak na zdjęciu poniżej.

Długo szukałem tego właśnie modelu, jest dość rzadko spotykany , ceniony w środowisku graczy jak i kolekcjonerów.

Oparty jest na elektronice Gottlieb System 80B. Posiada w sumie 3 ośmiobitowe procesory 6502.

Blat jest dość mocno rozbudowany. Posiada wiele funkcji.

Ma między innym ruletkę , opuszczaną rampę, funkcja multi ball i wiele wiele innych atrakcji.

A to podoba mi się najbardziej „Motyw HAZARD”.

Flipper był w dość złym stanie.

Pomalowany niechlujnie na niebiesko, wszystkie mechanizmy zacięte przez rozbitą na drobne kawałki hartowaną szybę. Elektronika też w nie najlepszym stanie sądząc po wylanej na płycie głównej baterii(akumulatorka) .

Cały remont zaplanowałem na kolejne etapy:

  • naprawa elektroniki, głównie naprawa polegająca (na samym początku) na wymianie elementów oraz obwodów PCB po wylanej baterii.
  • czyszczenie wstępne blatu
  • rozebranie blatu i dokładne wyczyszczenie go
  • demontaż wszystkich mechanizmów oraz rozebranie ich i remont
  • składanie wszystkich elementów i naprawa wynikłych w między czasie usterek.

Zgodnie z planem zabrałem się za elektronikę.

Na początek wyjaśnię jednak rolę każdej z płyt PCB.

Poniżej kilka zdjęć ukazujących problem wylania akumulatora i strawienia elementów oraz obwodu PCB CONTROL BOARD.

W tym momencie zabrakło mi elementów. Zamówiłem potrzebne  w TME i postanowiłem się zabrać za blat.

Wstępnie wyczyszczony, przygotowany do rozbiórki.

Czas na demontaż.

Czyszczenie oraz naprawa elementów.

Po remoncie poszczególnych elementów, zabrałem się do montażu ich na blacie.

Doszedłem do momentu, w którym trzeba było użyć elementów gumowych.

Miesiąc wcześniej zamówiłem w USA oryginalny  komplet naprawczy w skład którego wchodzi:

  • cztery bile. 3 duże jedna mała do ruletki
  • komplet wszystkich żarówek
  • bezpieczniki
  • nakrętki
  • wszystkie elementy gumowe
  • koplet naprawczy do wyrzutni
  • specjalny wosk do konserwacji blatu
  • ściereczkę z mikrofibry

 

Wymieniłem także wszystkie żarówki, było ich ok 40szt.

Po montażu wszystkich elementów zabrałem się za uruchomienie elektroniki.

I tu strasznie niemiłe zaskoczenie bo po włączeniu palił się bezpiecznik od cewek elektomagnesów a na wyświetlaczach wyświetlały się tylko krzaki.

Sugerowało by to że procesor nie wykonuje programu lub coś innego powoduje taki stan.

Zabrałem się jednak na pomiary napięć.

Na pierwszy ogień postanowiłem sprawdzić napięcie logiki. I tu ogarnęło mnie przerażenie.

Zamiast 5V było 12V. Odpowiedzialny za taki stan rzeczy by POWER REGULATOR.

Tak więc dobrałem mu się do du…y.

Poniżej schemat i w kółku zaznaczyłem głównego winowajce.

Rola którą ma tu spełniać, to regulacja napięcia wyjściowego.

Przerwa w tym obwodzie, skutkuje tym że nie ma sprzężenia zwrotnego i regulator traci pomiar napięcia wyjściowego. Myśląc że jest niskie dąży do tego by osiągnąć 5V na wyjściu ciągle je zwiększając. Nie mając tego napięcia, regulator robi się „przezroczysty” . Czyli napięcie wejściowe równa się wyjściowe. Stąd te 12V na logikę .

Było to złowieszcze odkrycie, gdyż nie miałem pewności czy nie ucierpiała logika.

Po przywróceniu napięcia logiki 5V , okazało się że na wyświetlaczu VFD pojawiły się napisy.

 

Strasznie się ucieszyłem, bo to sugerowało że przynajmniej elektronika płyty głównej przeżyła a procesor wykonuje program.

Nadal jednak nie było dźwięku.

Po przeanalizowaniu schematu i pomiarze napięć stwierdziłem że nie było kilku MAS.

Otóż wszystkie masy z elektroniki oraz blatu zbiegają się w jednym punkcie, czyli w zasilaczu.

Tam pięcioma wtykami wpięte były w płytkę masy. Niestety czyszczenie tych elementów nie pomogły.

Postanowiłem zlutować wszystkie masy i raz na zawsze pozbyć się tego problemu.

Od tej pory pojawił się dźwięk.

Następne kroki to żmudne czyszczenie i ustawianie czujników zdarzeń oraz dopracowanie szczegółów.

Na koniec impregnacja blatu.

 

Poniżej jeden z pierwszych filmów po remoncie.

 

 

I jeszcze jeden filmik.

Tu już gramy 🙂

 

Pozostaje teraz zamówić szybę i odmalować na oryginalny kolor fliperka.

Po tych operacjach mogę się zająć organizowaniem turniejów i uprawiać hazard pełną gębą 🙂

Pozdrawiam.

 

______________________________________________________________________

4-03-2019

 

Niestety pojawił się problem.

Podczas wielogodzinnych turniejów, okazało się iż flipper co jakiś (bliżej nie nieokreślony) czas resetuje się.

Efekt jest taki że wygląda to tak jak bym go od nowa włączył.

Wytnie kilka razy taki numer w ciągu minuty a później kilka dni chodzi bez zarzutu.

Jako że zdarza się to niespodziewanie i na krótki okres, postanowiłem się przygotować na następny raz.

Strategię przyjąłem następującą:

  • pomiar napięcia logiki 5V
  • ruszanie wszystkimi wtykami dochodzącymi do płyty by wyeliminować niestykające się piny
  • pomiar linii RESETU procesora

Dwa pierwsze punkty szybko wykluczyłem.

Zatem pomiar linii RESETU wykazał że podczas grania (jak się zawiesi) wskazuje na ułamek sekundy logiczne „0”.

Pomyślałem, mam cię robaczku 🙂

Zacząłem analizować schemat i doszedłem do magicznej płytki RESETU.

Po dokładnej analizie powyższego diagramu, doszedłem do wniosku że jest to sprzętowy WATCHDOG.

Jest to urządzenie lub program, najczęściej układ elektroniczny, wykrywający błędne działanie systemu, próbujący je naprawić lub zresetować bez udziału człowieka i zapobiec poważniejszej awarii.

Postanowiłem drogą eliminacji, odłączyć cały układ od płyty głównej. Miało by to na celu, sprawdzenie czy aby nie on błędnie działa wystawiając fałszywy sygnał RESETU.

I po wielu próbach grania, szybko okazało się, że to jednak nie on był przyczyną gdyż flipper resetował się dalej.

Cóż, trzeba był powrócić do schematu i analizować kolejne bloki linii RESETU.

Zaowocowało to tym, że natknąłem się na oto taki blok.

 

I tu trzeba zwrócić uwagę na trzy rzeczy.

Po pierwsze, układ Z4 bramka wyjście nóżka 4. Generuje sygnał RESETU.

Po drugie, blok z tranzystorami na górze nazwany DELAY CIRCUIT to obwód opóźniający.

Po trzecie, blok UP/DOWN MEMORY PROTECT LOGIC w raz z układem Z1 nazwanego ONE SHOT (jeden strzał).

Jak wynika ze schematu, sygnał RESETU kluczowany jest w pierwszej kolejności bramką z układu Z4 wyprowadzenie 1 i 2.  I tu postanowiłem w pierwszej kolejności zrobić pomiar, by złapać z kąd pochodzi fałszywy sygnał RESETU.         A mógł pochodzić z bloku DELAY CIRCUIT oraz UP/DOWN MEMORY PROTECT LOGIC w raz z układem Z1  ONE SHOT.

Podczas pomiary tych dwóch wyprowadzeń bramki Z4 nóżka 1,2 , okazało się że podczas niekontrolowanego RESETU, fałszywy sygnał pojawił sie na nóżce 1 bramki Z4.

Uffff , pomyślałem zaciskam pętle na szyi usterki.

Kolejny etap to pomiar sygnału wejściowego układu Z1 ONE SHOT. Pomiar na nóżce 11 tego układu wskazał na to że tu się już pojawia fałszywy sygnał RESETU, wykluczając jednocześnie błędne działanie jego samego.

Zatem znowu pętla się zaciska 🙂

Pozostało sprawdzić obwód z tranzystorem Q1, R8, R9 oraz diodą zenera VR1. Postanowiłem w pierwszej kolejności sprawdzić co dzieje się na bazie tranzystora Q1. Pomiar napięcia wykazał iż w momencie fałszywego resetu pojawia się tam napięcie bliskie zeru. Taki stan rzeczy w zasadzie nie powinien mieć miejsca gdyż, jak wynika ze schematu powinno być tam napięcie (zaraz po włączeniu flippera) bliskie napięcia przebicia diody zenera, czyli 3V. Tak więc zmierzyłem tę diodę i okazało się że ma prawie całkowite przebicie do masy.

Zatem, zacisnęła się pętla na szyi winowajcy.

Nie mając na miejscu takiej diody, wymyśliłem że do testów oszukam układ wstawiając potencjometr między kolektor a emiter tranzystora Q1 budując w ten sposób dzielnik w postaci potencjometru oraz rezystora R9,  wymuszając tym samym logiczne 1 na układzie Z1 nózka 11.

Tak też uczyniłem. Regulując potencjometrem trzeba było uzyskać odpowiednie napięcie by przekroczyć próg logicznego zera wchodząc w ten sposób w logiczne 1.

I eureka!!!!!!!

Flipper się uruchomił i zaczął poprawnie działać.

Pozostaje zamówić diodę zenera i przywrócić pierwotny stan układu.

Biorę się za testowanie 🙂

Pozdrawiam

 


Dioda przyszła, tak więc zabrałem się za lutowanie.

W pierwszej kolejności wylutowałem starą i zrobiłem pomiar. Oczywiście potwierdziło się to co wcześniej przewidziałem. Zwarcie.

 

Po wlutowaniu diody i usunięciu mojego crosa miedzy E i C tranzystora Q1 fliper się nie włączył.

Zrobiłem pomiar na Bazie Q1 i okazało się że napięcie jest ok 3V. Czyli zenerka pracuje. Cóż , pozostał tylko jeden element do podmianki, Q1.

 

Po wymianie flipper wystartował.

Pozostaje wyjąć płytę główną i wlutować elementy jak należy.

Pozdrawiam.

Related posts

Leave a Comment